Check Version Dependencies for AIMMS Developer and AIMMS PRO

There is a dependency between AIMMS Developer versions and AIMMS PRO versions. The version dependencies are minimal, but in some cases an upgrade of one product requires upgrade of the other.

In addition, some functionality requires upgrades in both AIMMS Developer and in AIMMS PRO.

These version dependencies are listed below:

  1. If you want to deploy AIMMS projects created using AIMMS 4.88 or newer, you will need AIMMS PRO 2.44 or newer.

  2. pro::storage::ExistsObject and pro::storage::ExistsBucket require at least AIMMS PRO 2.33 and AIMMS Developer 4.69

  3. If you want to deploy AIMMS Developer 4.66 or higher, you will need AIMMS PRO 2.28 or newer.

  4. Solver Lease: Requires at least AIMMS PRO 2.25 and AIMMS Developer 4.57

  5. If you want to use AIMMS Developer versions 4.38 or higher, you should use PRO 2.15 or higher. Lower PRO versions are incompatible with these AIMMS Developer versions.